不能更新
hyjjj 1月前 219

重新安装后,系统不能更新。很恼火…………


root@unassigned-hostname:/home/h# apt update

获取:1 http://apt.chinaredflag.cn kunlun InRelease [17.1 kB]
错误:1 http://apt.chinaredflag.cn kunlun InRelease
  由于没有公钥,无法验证下列签名: NO_PUBKEY 3407B5B0F04B8748
正在读取软件包列表... 完成
W: GPG 错误:http://apt.chinaredflag.cn kunlun InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 3407B5B0F04B8748
E: 仓库 “http://apt.chinaredflag.cn kunlun InRelease” 没有数字签名。
N: 无法安全地用该源进行更新,所以默认禁用该源。

N: 参见 apt-secure(8) 手册以了解仓库创建和用户配置方面的细节。


需要解决:1、“错误:1 http://apt.chinaredflag.cn kunlun InRelease ”  是什么问题?

                    2、“由于没有公钥,无法验证下列签名: NO_PUBKEY 3407B5B0F04B8748”  怎么解决?

                    3、“GPG 错误 ”  是1还是2引起,通过 --keyerver 可解决吗?

                    4、“仓库 “http://apt.chinaredflag.cn kunlun InRelease” 没有数字签名。”  签名?


上传的附件:
最新回复 (5)
  • 0 2
    这是最新的系统镜像吗?如果不是去下载一个最新的系统镜像
    这个问题的解决办法你试试这个
    wget -q -O - http://apt.chinaredflag.cn/key | sudo apt-key add -
    加一下公钥就可以了大概
    1月前 收起回复
    hyjjj : 加不了,提示没有key。用ventoy启动安装(0827)镜像不成功,就用了年初发行的最初版本,不能进图形界面,不能更新。只能startx。1月前回复
    啦啦队 : 回复 hyjjj: 换镜像换最新的1月前回复
    啦啦队 : 回复 hyjjj: 试试别的虚拟机安装比如vmware,不行就物理机1月前回复
    hyjjj : 回复 啦啦队: 一直是物理机安装,是双系统。1月前回复
  • 0 3
    进入/etc/apt,打开source.list,把这个源屏了就行。
    1月前 收起回复
    hyjjj : 屏了就没有源可加载了。1月前回复
  • 0 4
    如二楼的方法可能更好。
    1月前 回复
  • 0 5
    deb http://mirrors.ustc.edu.cn/debian stable main contrib non-free
    # deb-src http://mirrors.ustc.edu.cn/debian stable main contrib non-free
    deb http://mirrors.ustc.edu.cn/debian stable-updates main contrib non-free
    # deb-src http://mirrors.ustc.edu.cn/debian stable-updates main contrib non-free        


    # deb http://mirrors.ustc.edu.cn/debian stable-proposed-updates main contrib non-free
    # deb-src http://mirrors.ustc.edu.cn/debian stable-proposed-updates main contrib non-free


    deb https://mirrors.tuna.tsinghua.edu.cn/debian/ buster main contrib non-free
    # deb-src https://mirrors.tuna.tsinghua.edu.cn/debian/ buster main contrib non-free
    deb https://mirrors.tuna.tsinghua.edu.cn/debian/ buster-updates main contrib non-free
    # deb-src https://mirrors.tuna.tsinghua.edu.cn/debian/ buster-updates main contrib non-free
    deb https://mirrors.tuna.tsinghua.edu.cn/debian/ buster-backports main contrib non-free
    # deb-src https://mirrors.tuna.tsinghua.edu.cn/debian/ buster-backports main contrib non-free
    deb https://mirrors.tuna.tsinghua.edu.cn/debian-security buster/updates main contrib non-free
    # deb-src https://mirrors.tuna.tsinghua.edu.cn/debian-security buster/updates main contrib non-free

    这是稳定版的源,够不够,还有163和阿里云的,没加。
    如果你有兴趣,还有debian11和12的。
    1月前 收起回复
    hyjjj : 下面结果。1月前回复
  • hyjjj
    0 6
    更改源更新为debian11,重新安装。
    用ventoy制作的启动盘,三个红旗镜像0110,0528,0830版。调试bios能安装0110版。后面两版在ventoy中能进入grub2 ,再出现提示
    error:invalid magic number
    error:you need to load the kernel first
    到此安装失败。
    1月前 收起回复
    啦啦队 : 你的机器是什么配置的,能发下具体配置吗1月前回复
    hyjjj : 回复 啦啦队: 华硕K42EI37JZ-SL 处理器:4*Intel Core\tm i3-370M(2.4GHz) 内存容量:4GB 硬盘容量:320GB 显卡芯片: AMD Radeon HD 6470M1月前回复
    啦啦队 : 回复 hyjjj: 启动盘试试用软碟通做一下试试,你这个配置挺老的本了也1月前回复
返回